Scheduled Maintenance: ELD Open Interface (OI) Elog Events

Maintenance

Scheduled Maintenance: ELD Open Interface (OI) Elog Events

Status: Closed
Start:
End:
Duration: 13 hours 15 minutes
Affected Components:
Integration Services - Open Interface & M2M Brokers PeopleNet Integration Link EDriver Logs Functionality Open Interface Automated Work Flow (AWF) Dispatch Events to Trucks (OI) Automated Work Flow (AWF) Dispatch Events From Trucks (OI) Driver Logs Data (OI)
Update

Update: The date and time of this event have changed

On Saturday 7/27/24 at 8 pm Trimble Transportation will be deploying updates to the Open Interface which will impact these two services: elog_events and oi_pnet_elog_payroll.   This deployment will have an interruption of approximately 60 minutes when no elog_events records will pass through to your integrated system.



Impacted: 


  • Elog Events (elog_events):  login, logout, and duty status change events will not be available to the Link or dispatch applications. This could cause a delay in delivering Automated Workflow (AWF) dispatches if your integration is configured to look for the login event to send out the AWF dispatch.
  • Elog Payroll (oi_pnet_elog_payroll): Minimal impact to this service, which provides a daily summary of the time drivers spent in each duty status for a completed day. Most payroll records are returned shortly after midnight. For the time of day when the maintenance is scheduled, new payroll records would only be expected if corrections are made to a driver's log for a prior day(s). During the maintenance, those corrected payroll records will be delayed and transmitted after the maintenance has been completed. 



Not Impacted:  Drivers’ logging activities in the vehicle and driver portal are not impacted


During this deployment window, you may be able to manually send dispatches to vehicles if that functionality is available in your dispatch application. This functionality is available in the Link.


No changes need to be made to your integration. Requests for elog_events and oi_pnet_elog_payroll will be made to the same URL. The response will come back as it does now. After the deployment has been completed, all queued events will be delivered to the Link and dispatch applications. For any questions before the deployment, please contact Integration at integrationcases@peoplenetonline.com for more information.

Resolved

Dear Customer,

Planned Maintenance Affecting Service(s): {{ IncidentUpdate.ComponentsByName }}

Please be advised that the previously notified Planned Maintenance has been completed successfully.