Incident 3791: Canada Wireless Provider Degradation

Incident

Incident 3791: Canada Wireless Provider Degradation

Status: Closed
Start:
End:
Duration: 2 days 14 hours 40 minutes
Affected Components:
Wireless Network Communications PMG GSM Network - (Mexico and Canada Only) PMG LTE Network
Update

We have been informed by our Wireless Provider of an active service issue impacting Canadian users. Services have been restored for the Central region as of 2:30 PM CT (December 11, 2024), but remediation efforts for other regions are still ongoing.

Further updates will be provided as they become available.

Update

Fixes have been applied to the Eastern Canada region. While preliminary improvements are being observed, we continue to monitor the situation closely.

Thank you for your patience as we work with our partners toward ensuring full service restoration.

Resolved

Continued monitoring has confirmed that the applied fix remains effective, and wireless service across Canada has been restored and maintained.