Incident 3179 - Open Interface Delays
Incident Report for Trimble Transportation
Resolved
After continued monitoring, systems remain real-time. This incident is resolved since 3/22/2024 at 11:15 AM CST. A root cause analysis will be made available in 3-5 business days.
Posted Mar 25, 2024 - 12:04 CDT
Update
After continuous monitoring, we have not observed any Open Interface messaging delays since 11:15 AM CST. We will continue to monitor this service over the weekend. No further updates will be provided until the incident is officially closed
Posted Mar 22, 2024 - 18:08 CDT
Monitoring
Update: We are seeing recovery of Open Interface services due to the remediation applied by our engineering team. The efforts put in place are yielding positive results, and we are observing improvements in the functionality of our services. We will continue to monitor the situation closely and provide further updates as needed.
Posted Mar 22, 2024 - 11:15 CDT
Identified
Our engineers are currently applying a remediation effort that is believed to resolve the issues impacting our Open Interface services. We are actively working on implementing this solution, and we remain committed to resolving the issue as quickly as possible. Further updates will be provided as soon as more information becomes available.

Product Impact:

Open Interface
Integration Messages to Trucks
Automated Work Flow (AWF) dispatch events to trucks
Automated Work Flow (AWF) dispatch events from trucks
Edriver Driver Logs Data (Open Interface
Posted Mar 22, 2024 - 11:04 CDT
Update
We continue to investigate the issue impacting Open Interface (OI) services and have applied remediation efforts. However, relief on our Open Interface (OI) services has not been witnessed yet, and our engineering team's continues to work diligently on resolving the issue. We will provide further updates as soon as more information becomes available.


Product Impact:

Open Interface
Integration Messages to Trucks
Automated Work Flow (AWF) dispatch events to trucks
Automated Work Flow (AWF) dispatch events from trucks
Edriver Driver Logs Data (Open Interface)
Posted Mar 22, 2024 - 10:00 CDT
Investigating
We are currently experiencing intermittent delays with our Open Interface services, which are affecting a small portion of our customer base. Our engineers have re-engaged and are actively troubleshooting to resolve this issue. We will provide further updates as soon as more information becomes available.

Customers may encounter delays or occasional failures with the following services. If you experience any delays with these services, please contact our support center. We apologize for any inconvenience this may cause

Product Impact:

Open Interface
Integration Messages to Trucks
Automated Work Flow (AWF) dispatch events to trucks
Automated Work Flow (AWF) dispatch events from trucks
Edriver Driver Logs Data (Open Interface)
Posted Mar 22, 2024 - 08:44 CDT
Update
We are currently experiencing intermittent delays with our Open Interface services, which are affecting a small portion of our customer base. Our engineers have re-engaged and are actively troubleshooting to resolve this issue. We will provide further updates as soon as more information becomes available.

Customers may encounter delays or occasional failures with the following services. If you experience any delays with these services, please contact our support center. We apologize for any inconvenience this may cause

Product Impact:

Open Interface
Integration Messages to Trucks
Automated Work Flow (AWF) dispatch events to trucks
Automated Work Flow (AWF) dispatch events from trucks
Edriver Driver Logs Data (Open Interface)
Posted Mar 22, 2024 - 08:27 CDT
Monitoring
A fix has been applied and the Open Interface services are restored. We will continue to monitor.


Services Restored:

Open Interface
Integration Messages to Trucks
Automated Work Flow (AWF) dispatch events to trucks
Automated Work Flow (AWF) dispatch events from trucks
Edriver Driver Logs Data (Open Interface)
Posted Mar 21, 2024 - 16:17 CDT
Investigating
We are currently encountering intermittent delays with our Open Interface services. Our engineers are actively engaged and troubleshooting to resolve this issue. We will provide further updates as soon as more information becomes available.

Customers may experience delays or occasional failures with the following services. We apologize for this inconvenience.

Product Impact:

Open Interface
Integration Messages to Trucks
Automated Work Flow (AWF) dispatch events to trucks
Automated Work Flow (AWF) dispatch events from trucks
Edriver Driver Logs Data (Open Interface)
Posted Mar 21, 2024 - 16:04 CDT
This incident affected: Integration Services - Open Interface & M2M Brokers (Open Interface, Integration Messages to Trucks (OI), Automated Work Flow (AWF) Dispatch Events to Trucks (OI), Automated Work Flow (AWF) Dispatch Events From Trucks (OI), Driver Logs Data (OI)).