Incident 2932 - Intermittent Message Delay
Incident Report for Trimble Transportation
Resolved
Trimble Transportation engineer’s additional monitoring and executable remediation steps have effectively identified and resolved the messaging delays (forms) that have affected our customer base. A longer-term fix is also in the works. More details will be shared on that in the forthcoming RCA for this incident. This incident is considered resolved and will be set to a fixed status.
Posted Dec 09, 2022 - 16:57 CST
Monitoring
This incident remains resolved and the source of the form messaging delays has been identified and corrected. However, investigative measures are still underway to identify the root cause of this degradation. We will continue to monitor inbound message health until a root cause is identified, once identified we will set this incident to a fixed status. Currently all inbound messaging systems are healthy.
Posted Dec 02, 2022 - 15:19 CST
Update
Trimble Transportation engineers have resolved the issue delaying device forms messaging. Inbound messaging is currently processing in real-time and device-messaging delays have subsided. We will continue to monitor inbound message health over the weekend to ensure that system stability remains intact. Additional Monitoring is being created to alert engineers of a recurrence of a similar issue. This incident will remain in a watching status until further notice.
Posted Dec 02, 2022 - 15:18 CST
Update
Trimble Transportation engineers remain engaged and continue their remediation efforts. Collaborative teamwork is underway to assist with identifying the source of this messaging degradation. Corrective actions are being applied in an attempt to resolve these delays. PMG and PCG devices are affected and may see delays when sending form messages to these device types. We will provide an update when more information becomes available.
Posted Dec 02, 2022 - 11:03 CST
Investigating
Trimble Transportation engineers have re-engaged in this incident after receiving reports of the messaging forms delay re-occurrence. At the current moment, these message delays are only affecting PCG devices. Corrective actions continue to be taken in an attempt to remediate the source of these delays. We will provide an update as more information becomes available.
Posted Dec 02, 2022 - 08:49 CST
Monitoring
Trimble Transportation engineers’ corrective actions have positively affected inbound device messaging. All inbound messaging services have returned to real-time processing. We will continue to monitor inbound message health to ensure that system stability remains intact
Posted Dec 01, 2022 - 14:33 CST
Update
Trimble Transportation engineers have applied corrective actions to remediate these minor message device delays. We will continue to monitor performance throughout the evening and will provide an update as more information is available
Posted Nov 30, 2022 - 18:22 CST
Update
Trimble Transportation engineers continue to investigate a degradation affecting device messaging. Corrective actions are currently underway at this time to remediate these delays. The scope of this impact is limited to a small number of vehicles and not affecting all devices. We will provide an update when more information becomes available.
Posted Nov 30, 2022 - 14:47 CST
Investigating
Trimble engineers are investigating an intermittent delay in messaging between vehicles and the backend systems. A limited subset of all device types is affected by this degradation. We will provide updates as we discover more details about the disruption.
Posted Nov 30, 2022 - 11:04 CST
This incident affected: Device Communications (Mobile Originated PCG/Duo (Outbound messaging from the device to the back office), Mobile Terminated PCG/Duo (Inbound messaging from the back office to the device), Mobile Originated PMG (Outbound messaging from the device to the back office), Mobile Terminated PMG (Inbound messaging from the back office to the device)).