Incident 5177: Cloud Provider Service Interruption

Incident Report for Platform Science Mobility

Resolved

Our cloud provider's partial outage has been resolved. System monitoring confirms sustained recovery across affected services, marking this incident as resolved.
Posted Jun 12, 2025 - 17:17 CDT

Update

Engineers with our cloud provider remain engaged, and recovery efforts are ongoing.
Posted Jun 12, 2025 - 14:44 CDT

Update

Our cloud provider confirms continued remediation efforts, with recovery currently underway. Until fully resolved, users may experience temporary disruptions with Trimble Fleet Manager, ConnectedDriver, and driver logins.
Posted Jun 12, 2025 - 14:42 CDT

Identified

Trimble App Manager is temporarily unavailable due to a partial outage of our cloud provider. Engineers are engaged, and further updates will be provided as more information becomes available.
Posted Jun 12, 2025 - 14:05 CDT
This incident affected: Services (ConnectedDriver), Web (Trimble App Manager), and ELD (Instinct, Logins).