Incident 4789: Technical Phone Support Service Interruption

Incident Report for Trimble Transportation Mobility

Resolved

The telecom carrier issue affecting our Technical Support phone line is resolved, and all support services are fully operational.
Posted Apr 16, 2025 - 16:06 CDT

Identified

An issue with our telecom carrier is impacting our Technical Support line. A ticket has been raised with the provider, and we’re closely tracking their resolution efforts. Support remains available via the MyTransportation Hub, chat, or email:

• Chat Support (MyTransportation Hub): https://fleetsolutions.my.site.com/service
• Email Support: tm_support@platformscience.com
Posted Apr 16, 2025 - 14:33 CDT
This incident affected: Technical Support (Phone Support).