Incident 3133 - PCG (PeopleNet Connected Gateway) DUO & TG (Trimble Gateway) Communication Degradation
Incident Report for Trimble Transportation
Resolved
Update: The backlog of replayed data was fully completed at 4:10 AM CT, and this incident is now resolved after thorough monitoring. An RCA for this event (Root Cause Analysis) will be available within 3-5 business days.
Posted Feb 07, 2024 - 10:22 CST
Update
The incident disrupted inbound (Mobile Originated) events from both gateways and PMobile displays. This disruption impacted GPS, Vehicle Performance, and other vehicle-originated events, as well as messages, workflows, and dispatches coming from PMobile. We are currently replaying the impacted data, which may result in slight delays in inbound message delivery during the replay. If you notice any discrepancies, please reach out to your Customer Service Manager for assistance. We're actively monitoring the system as the backlog of messages is replayed. We estimate approximately eight hours.

We mistakenly reported that Instinct logins were affected due to a few customer reports that after further investigation were found to be unrelated to the incident. However, Fuel Authorization was notably affected due to its reliance on GPS data. Only Pmobile devices were affected during this incident.
Posted Feb 06, 2024 - 18:02 CST
Monitoring
We are actively engaged in monitoring all services. Our team remains vigilant to ensure the stability and reliability of our services. We will provide further updates as necessary.
Posted Feb 06, 2024 - 13:13 CST
Update
Update: We're beginning to see recovery across all services. No customer data was lost during this incident. However, as part of our recovery process, we will be conducting a replay of the data, which may result in minor messaging delays. We will continue to provide updates as progress unfolds. Thank you for your continued patience and understanding.
Posted Feb 06, 2024 - 12:51 CST
Update
Update: Unfortunately, the implemented resolution did not resolve the issue impacting services. Our Trimble Transporation engineers, in collaboration with our Third-Party Cloud provider, are now pursuing an alternative resolution, estimated to be completed within 35 minutes. This issue is the highest priority for our third-party provider. We apologize for any inconvenience this may cause.
Posted Feb 06, 2024 - 12:32 CST
Identified
Update: Our Trimble Transporation engineers have identified the issue and are actively working with our third-party cloud provider to remediate the ongoing issues. We apologize for any inconvenience this outage may be causing.
Posted Feb 06, 2024 - 11:51 CST
Update
Update: Our engineers have successfully resolved the issue with outbound device communications (mobile originated). However, inbound device communications (mobile terminated) remain impacted. We have received reports of some customers experiencing error messages, indicating a continued disruption in receiving messages. Consequently, we've escalated the severity of this incident to SEV 1. Our engineers are actively collaborating with our Third-Party cloud provider to address the ongoing issue. We will provide further updates as we work towards a resolution. Thank you for your understanding and patience as we work to restore full functionality.
Posted Feb 06, 2024 - 10:52 CST
Update
Update: Our engineers have reached out to our third-party cloud provider to further investigate the ongoing impact on communications. This issue is affecting messages, workflows, and dispatches sent to and received from PCG (Peoplenet Connected Gateway) TG (Trimble Gateway), and Duo devices since [9:22 AM] CT. We anticipate providing another update as soon as additional information becomes available. Thank you for your patience.
Posted Feb 06, 2024 - 10:37 CST
Investigating
Trimble Transportation engineers are investigating an issue impacting communications being sent to (messages, workflows, and dispatches) and being received from (messages, workflows, and location updates originating) PCG (Peoplenet Connected Gateway) TG (Trimble Gateway) and Duo devices beginning at [9:22 AM] CT. An update will be provided as more information becomes available.
Posted Feb 06, 2024 - 10:12 CST
This incident affected: Device Communications (Mobile Originated PCG/Duo (Outbound messaging from the device to the back office), Mobile Terminated PCG/Duo (Inbound messaging from the back office to the device), Mobile Originated Trimble Gateway (TG) (Outbound messaging from the device to the back office), Mobile Terminated Trimble Gateway (TG) (Inbound messaging from the back office to the device)) and Instinct (Instinct (Core Applications), Driver Workflow, Driver Media, Trimble App Manager (TAM), Vehicle Device Messaging).