Incident 6029: PeopleNet Fleet Manager Degradation

Incident Report for Platform Science Mobility

Resolved

PeopleNet Fleet Manager is stable and fully operational. This incident is resolved.
Posted Oct 21, 2025 - 16:59 CDT

Monitoring

Corrective actions have been applied, restoring PeopleNet Fleet Manager login capability for previously affected users.. Engineers are monitoring service health to confirm sustained stability. A final update will be provided once stability is verified.
Posted Oct 21, 2025 - 16:29 CDT

Investigating

Engineers are investigating an issue resulting in unsuccessful login attempts to the PeopleNet Fleet Manager. Further updates will be provided as the investigation proceeds.
Posted Oct 21, 2025 - 15:47 CDT
This incident affected: Web (PeopleNet Fleet Manager).