Incident 5714: Link Integration Instability

Incident Report for Platform Science Mobility

Resolved

Affected Link integrations have been successfully remediated, marking this incident as resolved.
Posted Aug 27, 2025 - 09:15 CDT

Identified

Impact for this incident is limited to select Link integration customers only.

A certificate update has caused data retrieval failures for select Link integrations. Affected Links will be unable to retrieve new data through the Open Interface API until they are paused, unloaded, and reloaded.

While impacted customers may perform these reloads themselves, our engineers will also continue working through tomorrow to identify and reload all impacted Links.

An update will be provided for this incident tomorrow morning. Impacted Link integration customers, please contact integrationcases@platformscience.com with any questions.
Posted Aug 26, 2025 - 21:36 CDT
This incident affected: Integration Services (Link).