Incident 5398: Technical Support Phone Line Interruption

Incident Report for Platform Science Mobility

Resolved

The issue with our telecom carrier affecting our Technical Support phone line is resolved. All support services are fully operational.
Posted Jul 16, 2025 - 12:41 CDT

Investigating

An issue with our telecom carrier is impacting our Technical Support phone line. A ticket has been raised with the provider, and we’re closely tracking their resolution efforts. Support remains available via the MyTransportation Hub, chat, or email:

• Chat Support (MyTransportation Hub): https://fleetsolutions.my.site.com/service
• Email Support: tm_support@platformscience.com
Posted Jul 16, 2025 - 12:26 CDT
This incident affected: Technical Support (Phone Support).