Incident 4649: Safety Analytics Data Retrieval Errors

Incident Report for Trimble Transportation Mobility

Resolved

We have resolved the data population issue in the Safety Analytics tab on the PFM. This incident is now considered resolved, with monitoring to continue into the following day.
Posted Mar 30, 2025 - 20:09 CDT

Investigating

We are investigating reports of an issue preventing data from populating within the Safety Analytics tab on the PFM. Updates will be provided as information becomes available.
Posted Mar 30, 2025 - 18:30 CDT
This incident affected: Services (Safety Analytics).